Search Button
shopping cart

HELP & SUPPORT

Why am I getting a Wi-Fi Signal Lost message on my VisionPRO (TH8320WF or RTH8580WF) thermostat?

Last updated

Share:

If you’re getting a Wi-Fi Signal Lost message on your VisionPRO (TH8320WF or RTH8580WF) thermostat, it probably lost internet connection. Please follow the steps below to remedy the issue.

VisionPRO-Wifi-Lost

To reconnect your device to Wi-Fi:

  1. Make sure your router is online.
  2. Go to your thermostat on the wall and remove it from its base.
  3. Wait for 1 minute.
  4. Add the thermostat back to its base on the wall.

If that doesn’t work, try the steps below:

Resetting Thermostat’s Wi-Fi Settings

  1. Press System.
  2. You’ll see 5 blank boxes at the bottom of the screen. Press and hold Middle Box for about 5 seconds to change the screen.
  3. Press the left set of arrows until the first number is 0900.
  4. Press the right set of arrows until the second number is 0.
  5. Press Done at the bottom-left corner.

Reconnecting Thermostat to Wi-Fi

  1. Make sure Wi-Fi Setup is displayed at the top of the screen.
  2. On a mobile device, view the list of available Wi-Fi networks.
  3. Connect to NewThermsotat_[series of numbers/letters].
  4. Wait for your browser to automatically open a setup screen. If this doesn’t happen, open a new browser on your mobile device and go to the web address 192.168.1.1.
  5. Find the name of your home network and press Red Button below it.
  6. Enter your home network’s password and press Connect.

If you’re still having issues, please call Honeywell Customer Care at 1-855-733-5465.

CONTACT US

Message Resideo

MESSAGE US

Message us on Twitter for help with our products.

Monday through Friday:
9am to 6pm CDT
Saturday and Sunday:
9am to 5pm CDT

Live Chat with Resideo

CHAT US

Connect with an agent for quick assistance.

Monday through Friday:
9am to 8pm CDT
Saturday and Sunday
9am to 5pm CDT

Call Resideo

CALL US

Speak directly with an agent for help with our products.